[Python-Dev] s1 == (sf % (s1 / sf))? A bad idea?

Skip Montanaro skip@pobox.com (Skip Montanaro)
Tue, 3 Apr 2001 20:19:50 -0500 (CDT)


    Tim> Finally, since .scanf() is a rotten method name (like .join()
    Tim> before it, it doesn't make clear which operand is scanned and which
    Tim> format), try something like format.scanning(string) instead.

Hmmm... If method names are the way to go, I'd much rather we found a more
active verb name than "scanning".  How about "extract" or "slice"?  Even
simply "scan" sounds better to me.

Back to the infix operator idea, I agree with Peter on the one hand that
there's a certain symmetry to using infix "/" and with the opposing camp
that the only reason "%" works for emitting strings is the use of C's %
format character.  "*" sort of suggests exploding... ;-)

Skip