[Python-Dev] None as a keyword / class methods

Mark Hammond mhammond@skippinet.com.au
Thu, 23 Mar 2000 09:29:53 -0800


...
> If None becomes a keyword, I would like to ask whether it could be used to
> signal that a method is a class method, as opposed to an instance method:
>
>     def classMethod(None, arg):
>         ...equivalent of C++ 'static'...
...

> I'd also like to ask (separately) that assignment to None be defined as a
> no-op, so that programmers can write:
>
>     year, month, None, None, None, None, weekday, None, None =
> gmtime(time())

In the vernacular of a certain Mr Stein...

+2 on both of these :-)

[Although I do believe "static method" is a better name than "penguin" :-]


Mark.