[Python-Dev] PEP 201 - Parallel iteration

Peter Schneider-Kamp peter@schneider-kamp.de
Mon, 17 Jul 2000 23:39:31 +0000


Vladimir Marangozov wrote:
> 
> I don't feel comfortable with it. Period.
> You might want to see what http://www.dict.org has to say about it.
> 
> Looking at the examples for this builtin function, and without thinking
> too much about the name, I'd call it - fold().

Please, don't!!! As far as I can remember, fold is the "reduce of the
functional languages". At least it is that in Haskell.

Here's a quote from the Journal of Functional Programming (July 1999):
"In functional programming, fold is a standard operator that
encapsulates a simple pattern of recursion for processing lists."

BTW: I still like zip() and as someone said: dir and del have
     the same problem/not-a-problem

Peter
--
Peter Schneider-Kamp          ++47-7388-7331
Herman Krags veg 51-11        mailto:peter@schneider-kamp.de
N-7050 Trondheim              http://schneider-kamp.de