[Python-Dev] Re: A small proposed change to dictionaries' "get" method

Barry A. Warsaw bwarsaw@beopen.com
Thu, 3 Aug 2000 10:41:10 -0400 (EDT)


>>>>> "M" == M  <mal@lemburg.com> writes:

    M> The following one-liner already does what you want:

    M> 	d[word] = d.get(word, []).append('world')

    M> ... and it's in no way more readable than your proposed
    M> .put() line ;-)

Does that mean it's less readable?  :)

-Barry