[Python-checkins] cpython: issue9859: rename CPyMatchTest to APIMismatchTest and add @support.cpython_only.

gregory.p.smith python-checkins at python.org
Tue Apr 14 22:26:44 CEST 2015


https://hg.python.org/cpython/rev/9903368b9d7b
changeset:   95656:9903368b9d7b
user:        Gregory P. Smith <greg at krypto.org>
date:        Tue Apr 14 13:24:34 2015 -0700
summary:
  issue9859: rename CPyMatchTest to APIMismatchTest and add @support.cpython_only.

files:
  Lib/test/test_io.py |  5 +++--
  1 files changed, 3 insertions(+), 2 deletions(-)


diff --git a/Lib/test/test_io.py b/Lib/test/test_io.py
--- a/Lib/test/test_io.py
+++ b/Lib/test/test_io.py
@@ -719,7 +719,8 @@
     pass
 
 
-class CPyMatchTest(unittest.TestCase):
+ at support.cpython_only
+class APIMismatchTest(unittest.TestCase):
 
     @unittest.skip('test to be fixed by issue 9858')
     def test_RawIOBase_io_in_pyio_match(self):
@@ -3733,7 +3734,7 @@
 
 
 def load_tests(*args):
-    tests = (CIOTest, PyIOTest, CPyMatchTest,
+    tests = (CIOTest, PyIOTest, APIMismatchTest,
              CBufferedReaderTest, PyBufferedReaderTest,
              CBufferedWriterTest, PyBufferedWriterTest,
              CBufferedRWPairTest, PyBufferedRWPairTest,

-- 
Repository URL: https://hg.python.org/cpython


More information about the Python-checkins mailing list