[Python-checkins] CVS: python/dist/src/Misc NEWS,1.299,1.300

Tim Peters tim_one@users.sourceforge.net
Thu, 25 Oct 2001 22:06:52 -0700


Update of /cvsroot/python/python/dist/src/Misc
In directory usw-pr-cvs1:/tmp/cvs-serv13745/python/Misc

Modified Files:
	NEWS 
Log Message:
Generalize dictionary() to accept a sequence of 2-sequences.  At the
outer level, the iterator protocol is used for memory-efficiency (the
outer sequence may be very large if fully materialized); at the inner
level, PySequence_Fast() is used for time-efficiency (these should
always be sequences of length 2).

dictobject.c, new functions PyDict_{Merge,Update}FromSeq2.  These are
wholly analogous to PyDict_{Merge,Update}, but process a sequence-of-2-
sequences argument instead of a mapping object.  For now, I left these
functions file static, so no corresponding doc changes.  It's tempting
to change dict.update() to allow a sequence-of-2-seqs argument too.

Also changed the name of dictionary's keyword argument from "mapping"
to "x".  Got a better name?  "mapping_or_sequence_of_pairs" isn't
attractive, although more so than "mosop" <wink>.

abstract.h, abstract.tex:  Added new PySequence_Fast_GET_SIZE function,
much faster than going thru the all-purpose PySequence_Size.

libfuncs.tex:
- Document dictionary().
- Fiddle tuple() and list() to admit that their argument is optional.
- The long-winded repetitions of "a sequence, a container that supports
  iteration, or an iterator object" is getting to be a PITA.  Many
  months ago I suggested factoring this out into "iterable object",
  where the definition of that could include being explicit about
  generators too (as is, I'm not sure a reader outside of PythonLabs
  could guess that "an iterator object" includes a generator call).
- Please check my curly braces -- I'm going blind <0.9 wink>.

abstract.c, PySequence_Tuple():  When PyObject_GetIter() fails, leave
its error msg alone now (the msg it produces has improved since
PySequence_Tuple was generalized to accept iterable objects, and
PySequence_Tuple was also stomping on the msg in cases it shouldn't
have even before PyObject_GetIter grew a better msg).


Index: NEWS
===================================================================
RCS file: /cvsroot/python/python/dist/src/Misc/NEWS,v
retrieving revision 1.299
retrieving revision 1.300
diff -C2 -d -r1.299 -r1.300
*** NEWS	2001/10/25 21:53:30	1.299
--- NEWS	2001/10/26 05:06:50	1.300
***************
*** 5,8 ****
--- 5,13 ----
  Type/class unification and new-style classes
  
+ - dictionary() now accepts an iterable object producing 2-sequences.
+   For example, dictionary(d.items()) == d for any dictionary d.  The
+   argument, and the elements of the argument, can be any iterable
+   objects.
+ 
  - Methods of built-in types now properly check for keyword arguments
    (formerly these were silently ignored).  The only built-in methods
***************
*** 31,34 ****
--- 36,43 ----
  
  C API
+ 
+ - New function PySequence_Fast_GET_SIZE() returns the size of a non-
+   NULL result from PySequence_Fast(), more quickly than calling
+   PySequence_Size().
  
  New platforms