[issue19266] Rename contextlib.ignore to contextlib.suppress

Raymond Hettinger report at bugs.python.org
Wed Oct 16 11:11:29 CEST 2013


Raymond Hettinger added the comment:

I oppose abort_on() because it implies that it aborts the program.

The word trap() is accurate but will be weird-sounding and non-communicative to users without a CS background:

    with trap(sqlite3.OperationalError):
        cursor.execute('CREATE TABLE dict (key text, value text)')

The word "trap" in a CS context is also archaic and falling out of use.  (Remember, glob.glob() was a good name in 1990 but most people now don't get know the reference to "globbing" and so the word is meaningless gobbledygook to them).

Please give some weight to the fact the ignore() was checked in for seven months, it was presented at a conference, I've put it front of working Python programmers to use in real code, and I've checked to see how it reads in the try/except/pass code examples in the standard library.   Don't throw away this work on a whim.

----------

_______________________________________
Python tracker <report at bugs.python.org>
<http://bugs.python.org/issue19266>
_______________________________________


More information about the Python-bugs-list mailing list