[Python-3000] PEP: rename it.next() to it.__next__(), add a next() built-in

Georg Brandl g.brandl at gmx.net
Mon Mar 5 23:54:25 CET 2007


Greg Ewing schrieb:
> Ka-Ping Yee wrote:
> 
>>     Just like getattr, two-argument next(iter, sentinel)
>>     returns sentinel if StopException is caught.
> 
> +1. I've written a number of pieces of code where this
> would have made things neater. Just about any place
> where I've used .next() explicitly, in fact -- it
> always seems awkward having to deal with StopIteration.

Indeed, you almost always have to have a try-except StopIteration-
wrapper around "manual" calls to .next(). In many of these cases,
a default value would make things nicer: +1.

Georg



More information about the Python-3000 mailing list