[pypy-commit] pypy hpy: give a better name to this helper, it makes it much easier to debug translation errors

antocuni pypy.commits at gmail.com
Mon Dec 2 06:25:02 EST 2019


Author: Antonio Cuni <anto.cuni at gmail.com>
Branch: hpy
Changeset: r98211:987c3b5d033e
Date: 2019-12-01 12:08 +0100
http://bitbucket.org/pypy/pypy/changeset/987c3b5d033e/

Log:	give a better name to this helper, it makes it much easier to debug
	translation errors

diff --git a/pypy/module/hpy_universal/apiset.py b/pypy/module/hpy_universal/apiset.py
--- a/pypy/module/hpy_universal/apiset.py
+++ b/pypy/module/hpy_universal/apiset.py
@@ -52,6 +52,7 @@
                 return wrapper
             def get_llhelper(space):
                 return llhelper(ll_functype, make_wrapper(space))
+            get_llhelper.__name__ = 'get_llhelper_%s' % fn.__name__
             fn.get_llhelper = get_llhelper
 
             # basename


More information about the pypy-commit mailing list