[pypy-commit] pypy py3.5: Rename ArrayData to ArrayBuffer

rlamy pypy.commits at gmail.com
Sat May 27 22:54:29 EDT 2017


Author: Ronan Lamy <ronan.lamy at gmail.com>
Branch: py3.5
Changeset: r91423:c1a9982a0266
Date: 2017-05-28 03:54 +0100
http://bitbucket.org/pypy/pypy/changeset/c1a9982a0266/

Log:	Rename ArrayData to ArrayBuffer

diff --git a/pypy/module/array/interp_array.py b/pypy/module/array/interp_array.py
--- a/pypy/module/array/interp_array.py
+++ b/pypy/module/array/interp_array.py
@@ -258,7 +258,7 @@
             lltype.free(oldbuffer, flavor='raw')
 
     def buffer_w(self, space, flags):
-        return ArrayView(ArrayData(self), self.typecode, self.itemsize, False)
+        return ArrayView(ArrayBuffer(self), self.typecode, self.itemsize, False)
 
     def descr_append(self, space, w_x):
         """ append(x)
@@ -848,7 +848,7 @@
     v.typecode = k
 unroll_typecodes = unrolling_iterable(types.keys())
 
-class ArrayData(RawBuffer):
+class ArrayBuffer(RawBuffer):
     _immutable_ = True
     readonly = False
     def __init__(self, w_array):


More information about the pypy-commit mailing list