[Numpy-discussion] scipy.base

pearu at cens.ioc.ee pearu at cens.ioc.ee
Wed Apr 13 04:06:00 EDT 2005


On Mon, 11 Apr 2005, Travis Oliphant wrote:

> >When using setup_scipy.py for building, the ndarray package is installed
> >as scipy.base and
> >
> >  from scipy.base import *
> >
> >should work equivalently to
> >
> >  from ndarray import *
> >
> >for instance.
> >  
> >
> I don't like from ndarray import *.   It's only been a place-holder.  
> Let's get rid of it as soon as possible.

Done in CVS.

> >To clean up Numeric3 CVS repository completely then Include, Src, Lib,
> >CodeGenerators directories should be moved under the scipy/base directory.
> >However, this step can be omitted if you would prefer working with files
> >at the top directory of Numeric3. 
> >
> I have no preference here.   Whatever works best.

Directory Include/ndarray/ is now moved to scipy/base/Include/scipy/base/.
I'l move other directories as well.

> >First, how to name Numeric3 project when it installs scipy.base,
> >scipy.distutils, Numeric packages, etc? This name will be used when
> >creating source distributions and also as part of the path where header
> >files will be installed. At the moment setup_scipy.py uses the name
> >'ndarray'. 
> >
> I don't like the name ndarray -- it's too limiting.  Why not scipy_core? 
> 
> >In fact, 'Numeric' (with version 3x.x) would be also an option but that
> >would be certainly cause some problems when one wants both Numeric 2x.x
> >and Numeric 3x.x to be installed in the system, the header files would end
> >up in the same directory, for instance. As a workaround, we could force
> >installing Numeric3 header files to <prefix>/include/Numeric/3/ or
> >something. I acctually like this idea but I wonder what other think about
> >this.
> >  
> >
> How about include/scipy?

Without going into details of distutils restrictions for various options,
I found that

  #include "scipy/base/arrayobject.h"

option works best. And the name of the Numeric3 package is now scipy_core.
All this is implemented in Numeric3 CVS now.

> >Second, is it already possible to use ndarray C/API as a replacement of
> >Numeric C/API, i.e. would simple replacement of 
> >
> >  #include "Numeric/arrayobject.h"
> >
> >with 
> >
> >  #include "ndarray/arrayobject.h"
> >
> >work? And if not, will it ever be? This would be interesting to know as an
> >extension writer.
> >  
> >
> This should work fine.

Great!

Thanks,
Pearu





More information about the NumPy-Discussion mailing list