[Mailman-Developers] problem with view other subscriptions..

Harald Meland Harald.Meland@usit.uio.no
19 May 2000 19:24:06 +0200


[Matt Davis]

> On 19 May 2000, Harald Meland wrote:
> 
> > Oops.  At first I called the new function argument "mlist", but a
> > little later I renamed it to "from_mlist".  However, I forgot to make
> > the same change in the function's body.  The fix should be rather
> > straightforward to do by hand, but here it is as a patch (against
> > current CVS, not your patched version of the file).
> 
> Got this now..

This is getting embarassing :-\, my previous patch neglected to store
freshly instantiated MailList objects in the variable "l".  The line
to fix is

   436              MailList.MailList(i, lock=lock)

Change this to

   436              l = MailList.MailList(i, lock=lock)

and things should hopefully start working again.

> BTW, i love untested stuff.. If being a genuie pig is the only way i
> can help, i'm game!

OK, then -- for your enjoyment only, I have neglected to test this
change, too :)
-- 
Harald