[Cython] can we deprecate for-from loops?

William Stein wstein at gmail.com
Sun Oct 11 17:46:49 EDT 2015


On Sun, Oct 11, 2015 at 1:01 PM, Jeroen Demeyer <jdemeyer at cage.ugent.be> wrote:
> On 2015-10-11 16:30, Stefan Behnel wrote:
>>
>> Hi!
>>
>> The syntax construct "for i from 0 <= i < 10" has been silently outdated
>> for years. Can we start issuing a warning that normal range() loops are
>> preferred?
>
>
> Is there anything wrong with the for ... from ... syntax? In more
> complicated situations I find
>
> for i from a <= i < b by s
>
> more readable than the equivalent for i in range() statement.
>
> I know it's not a strong argument, it's just something to keep in mind.

A weak argument for removing the " for i from a <= i < b by s" syntax:

- it makes it more difficult for somebody who only knows Python to
read Cython code (adding one new idea that is not necessary).

- it doesn't look Pythonic (purely subjective)

 -- William

>
>
> _______________________________________________
> cython-devel mailing list
> cython-devel at python.org
> https://mail.python.org/mailman/listinfo/cython-devel



-- 
William (http://wstein.org)


More information about the cython-devel mailing list