[Baypiggies] padding variable assignments, why is it bad?

David Berthelot david.berthelot at gmail.com
Fri Aug 10 19:37:08 CEST 2012


Yes, I share this habit, I find it especially readable when writing
data models in SQLAlchemy.
Me too, I'd like to know why it is a bad thing.

On Fri, Aug 10, 2012 at 10:19 AM, Aleksandr Miroslav
<alexmiroslav at gmail.com> wrote:
> (Reading this email requires a monospaced font.)
>
> I do this a lot in my code:
>
>     foo          = 1
>     foo_bar      = 2
>     foo_bar_quux = 3
>
> but pep8, which I started using recently, considers this wrong, so I
> have to rewrite to the more common form:
>
>     foo = 1
>     foo_bar = 2
>     foo_bar_quux = 3
>
> which I think sacrifices readability. Perhaps this is the n00b in me
> talking, but why is this considered bad?
> _______________________________________________
> Baypiggies mailing list
> Baypiggies at python.org
> To change your subscription options or unsubscribe:
> http://mail.python.org/mailman/listinfo/baypiggies


More information about the Baypiggies mailing list