[Async-sig] Asyncio loop instrumentation

Pau Freixes pfreixes at gmail.com
Tue Jan 2 12:00:18 EST 2018


Agree, poll_start and poll_end suit much better.

Thanks for the feedback.

On Tue, Jan 2, 2018 at 1:34 AM, INADA Naoki <songofacandy at gmail.com> wrote:
>>>> For this proposal [4], POC, I've preferred make a reduced list of events:
>>>>
>>>> * `loop_start` : Executed when the loop starts for the first time.
>>>> * `tick_start` : Executed when a new loop tick is started.
>>>> * `io_start` : Executed when a new IO process starts.
>>>> * `io_end` : Executed when the IO process ends.
>>>> * `tick_end` : Executed when the loop tick ends.
>>>> * `loop_stop` : Executed when the loop stops.
>>>
>>> What do you call a "IO process" in this context?
>>
>> Basically the call to the `select/poll/whatever` syscall that will ask
>> for read or write to a set of file descriptors.
>
> `select/poll/whatever` syscalls doesn't ask for read or write.
> It waits for read or write (more accurate, waits for readable or
> writable state).
>
> So poll_start / poll_end looks better name to me.
>
> INADA Naoki  <songofacandy at gmail.com>
>
>
>>
>> Thanks,
>>
>> --
>> --pau
>> _______________________________________________
>> Async-sig mailing list
>> Async-sig at python.org
>> https://mail.python.org/mailman/listinfo/async-sig
>> Code of Conduct: https://www.python.org/psf/codeofconduct/



-- 
--pau


More information about the Async-sig mailing list